W3C home > Mailing lists > Public > public-audio@w3.org > October to December 2012

[Bug 20500] New: enumerate is misnomer

From: <bugzilla@jessica.w3.org>
Date: Mon, 24 Dec 2012 08:10:02 +0000
To: public-audio@w3.org
Message-ID: <bug-20500-5429@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=20500

            Bug ID: 20500
           Summary: enumerate is misnomer
    Classification: Unclassified
           Product: AudioWG
           Version: unspecified
          Hardware: PC
                OS: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: MIDI API
          Assignee: dave.null@w3.org
          Reporter: w3c@marcosc.com
        QA Contact: public-audio@w3.org

enumerateInputs() and enumerateOutputs() are misnomers (apart from being
somewhat hard to type and confusingly named). From reading the spec, my
understanding is that methods just "get" a copy of the currently available to
the system at the time the method is invoked. The methods don't actually
"enumerate" anything in this sense (i.e., give you a number or iterate over a
sequence using numbers, etc). Can I kindly request that those two methods be
renamed:

getInputs();
getOutputs();

or just:
inputs()
outputs()

The above are shorter and more closely match the intent of the methods, which
is specified as:
"Returns a list of the MIDI input ports available on the system."
"Returns a list of the MIDI output ports available on the system."

The above definitions should also clarify that these are not a live list (i.e.,
are not updated as new midi devices are updated or removed from the device).

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
Received on Monday, 24 December 2012 08:10:04 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:50:04 UTC