[Web MIDI API] enumerate is misnomer

Hi, 
IMHO, enumerateInputs() and enumerateOutputs() are misnomers (apart from being somewhat hard to type and confusingly named). From reading the spec, my understanding is that methods just "get" a copy of the currently available to the system at the time the method is invoked. The methods don't actually "enumerate" anything in this sense (i.e., give you a number or iterate over a sequence using numbers, etc). Can I kindly request that those two methods be renamed: 

getInputs();
getOutputs();

or just:
inputs()
outputs()

The above are shorter and more closely match the intent of the methods, which is specified as: 
"Returns a list of the MIDI input ports available on the system."
"Returns a list of the MIDI output ports available on the system."

The above definitions should also clarify that these are not a live list (i.e., are not updated as new midi devices are updated or removed from the device).  

-- 
Marcos Caceres
http://datadriven.com.au

Received on Sunday, 23 December 2012 20:07:22 UTC