W3C home > Mailing lists > Public > public-audio@w3.org > October to December 2012

[Bug 18332] Node creation method naming inconsistencies

From: <bugzilla@jessica.w3.org>
Date: Tue, 16 Oct 2012 20:11:05 +0000
To: public-audio@w3.org
Message-ID: <bug-18332-5429-faDZTL37Ed@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=18332

Chris Rogers <crogers@google.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |ASSIGNED

--- Comment #3 from Chris Rogers <crogers@google.com> ---
(In reply to comment #2)
> (In reply to comment #1)
> > How about being consistent by removing the "Node" suffix, leaving all the
> > "create" methods the same, except for:
> > 
> > createGainNode -> createGain
> > createDelayNode -> createDelay
> > 
> > createJavaScriptNode -> createScriptProcessor
> > 
> > I'm less sure about the naming of "createScriptProcessor".  Some have suggested
> > that we might use other scripting languages than JavaScript, so that shouldn't
> > be a part of the name.
> 
> I think we need to resolve Bug 17407 before moving forward with this one.

Now that 17407 is resolved, how do the two method name-changes sound?

-- 
You are receiving this mail because:
You are the QA Contact for the bug.
Received on Tuesday, 16 October 2012 20:11:09 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:50:03 UTC