W3C home > Mailing lists > Public > public-audio@w3.org > October to December 2012

[Bug 18332] Node creation method naming inconsistencies

From: <bugzilla@jessica.w3.org>
Date: Wed, 03 Oct 2012 07:07:27 +0000
Message-Id: <E1TJJ3H-0007ew-Hw@jessica.w3.org>
To: public-audio@w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=18332

--- Comment #2 from Marcus Geelnard (Opera) <mage@opera.com> 2012-10-03 07:07:26 UTC ---
(In reply to comment #1)
> How about being consistent by removing the "Node" suffix, leaving all the
> "create" methods the same, except for:
> 
> createGainNode -> createGain
> createDelayNode -> createDelay
> 
> createJavaScriptNode -> createScriptProcessor
> 
> I'm less sure about the naming of "createScriptProcessor".  Some have suggested
> that we might use other scripting languages than JavaScript, so that shouldn't
> be a part of the name.

I think we need to resolve Bug 17407 before moving forward with this one.

-- 
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Wednesday, 3 October 2012 07:07:28 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 21:50:03 UTC