W3C home > Mailing lists > Public > public-audio@w3.org > July to September 2012

[Bug 17724] MIDI API naming

From: <bugzilla@jessica.w3.org>
Date: Mon, 13 Aug 2012 18:12:26 +0000
Message-Id: <E1T0z7q-00081j-V4@jessica.w3.org>
To: public-audio@w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=17724

Chris Wilson <cwilso@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|FIXED                       |

--- Comment #5 from Chris Wilson <cwilso@gmail.com> 2012-08-13 18:12:26 UTC ---
(In reply to comment #4)
> Sounds uncontroversial. 
> 
> Marking as FIXED, will close within a week if there is no objection.

I'm still not a fan of this naming.  "MIDIInput" could be a representation of a
port, it could be a buffer of data, ... I still think it is clearer if "Port"
is appended on the Input and Output types.  Do we have other examples of how
types are described from elsewhere in the platform?

-- 
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Monday, 13 August 2012 18:12:29 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Monday, 13 August 2012 18:12:29 GMT