W3C home > Mailing lists > Public > public-audio@w3.org > July to September 2012

[Bug 17724] MIDI API naming

From: <bugzilla@jessica.w3.org>
Date: Sun, 12 Aug 2012 14:47:32 +0000
Message-Id: <E1T0ZS0-00046a-V1@jessica.w3.org>
To: public-audio@w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=17724

--- Comment #2 from Jussi Kalliokoski <jussi.kalliokoski@gmail.com> 2012-08-12 14:47:32 UTC ---
(In reply to comment #1)
> I think this might help clear up some confusion.  I would suggest keeping
> "Port" as part of the name for the input and output ports, i.e.:
> 
> MIDIDevice -> MIDIPort
> MIDIInputDevice -> MIDIInputPort
> MIDIOutputDevice -> MIDIOutputPort

Hmm, I decided to drop the "Port" suffix anyway as a MIDIInput/MIDIOutput can't
really be anything other than a port in this case. Changes applied in:
https://dvcs.w3.org/hg/audio/rev/df28ddef0c73

-- 
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Sunday, 12 August 2012 14:47:35 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Sunday, 12 August 2012 14:47:35 GMT