W3C home > Mailing lists > Public > public-audio@w3.org > July to September 2012

[Bug 18332] New: Node creation method naming inconsistencies

From: <bugzilla@jessica.w3.org>
Date: Thu, 19 Jul 2012 13:40:33 +0000
To: public-audio@w3.org
Message-ID: <bug-18332-5429@http.www.w3.org/Bugs/Public/>
https://www.w3.org/Bugs/Public/show_bug.cgi?id=18332

           Summary: Node creation method naming inconsistencies
           Product: AudioWG
           Version: unspecified
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Web Audio API
        AssignedTo: crogers@google.com
        ReportedBy: mage@opera.com
         QAContact: public-audio@w3.org


http://dvcs.w3.org/hg/audio/raw-file/tip/webaudio/specification.html#AudioContext-section

The methods for creating different AudioNodes use inconsistent naming
conventions. Here is a list of current method -> type mappings:

createBufferSource -> AudioBufferSourceNode
createMediaElementSource -> MediaElementAudioSourceNode
createMediaStreamSource -> MediaStreamAudioSourceNode
createJavaScriptNode -> JavaScriptAudioNode
createAnalyser -> RealtimeAnalyserNode
createGainNode -> AudioGainNode
createDelayNode -> DelayNode
createBiquadFilter -> BiquadFilterNode
createPanner -> AudioPannerNode
createConvolver -> ConvolverNode
createChannelSplitter -> AudioChannelSplitter
createChannelMerger -> AudioChannelMerger
createDynamicsCompressor -> DynamicsCompressorNode
createOscillator -> Oscillator

Apart from the inconsistently named AudioNode interfaces (see Bug 17407), the
constructors also use a fair mix of:

* Complete interface name, e.g. createDelayNode and createOscillator
* With Node suffix, e.g. createGainNode, createDelayNode
* Without Node suffix, e.g. createBufferSource, createConvolver
* With key parts of the name dropped, e.g. createAnalyzer

The only consistency I can see is that any occurrences of "Audio" in the
interface names have been dropped in the create-method names.

Suggestion: Include the entire interface name, possibly excluding Audio prefix
and/or Node suffix (as long as it's the same for all methods).

-- 
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the QA contact for the bug.
Received on Thursday, 19 July 2012 13:47:00 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 19 July 2012 13:47:08 GMT