W3C home > Mailing lists > Public > public-audio@w3.org > July to September 2012

[Bug 17334] (setTargetValueAtTime): AudioParam.setTargetValueAtTime is misleading and underdefined

From: <bugzilla@jessica.w3.org>
Date: Thu, 05 Jul 2012 14:34:01 +0000
Message-Id: <E1Smn85-0006e0-Qx@jessica.w3.org>
To: public-audio@w3.org
https://www.w3.org/Bugs/Public/show_bug.cgi?id=17334

Olivier Thereaux <olivier.thereaux@bbc.co.uk> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |REOPENED
         Resolution|FIXED                       |

--- Comment #3 from Olivier Thereaux <olivier.thereaux@bbc.co.uk> 2012-07-05 14:34:01 UTC ---
Mailing-list discussion on this topic between Ray Bellis, Chris Rogers, Marcus
Geelnard and myself:
http://lists.w3.org/Archives/Public/public-audio/2012AprJun/thread.html#msg856

Marcus has a pretty good summary, and raises something interesting:
http://lists.w3.org/Archives/Public/public-audio/2012AprJun/0865.html

«
Once you understand what the function does, the name makes sense. However,  
the name alone does not make it easy to understand what it does.

I think that the confusion (at least for me) is that "setTargetValue" is  
very similar to "setValue", and I fear that many will have them mixed up.  
Generally speaking, the "set" term indicates a zero-duration operation.  
I'd much rather see that methods that cause gradual changes use a  
consistent naming convention, excluding the term "set".

I think that a more appropriate name could be "approachValueAtTime" or  
"startApproachingValueAtTime".

Similarly the name "setValueCurveAtTime" would do better without "set".  
Any suggestions? (I'm out of ideas right now)
»

-- 
Configure bugmail: https://www.w3.org/Bugs/Public/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.
Received on Thursday, 5 July 2012 14:34:11 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Thursday, 5 July 2012 14:34:11 GMT