W3C home > Mailing lists > Public > public-audio@w3.org > April to June 2012

Re: [Bug 17334] (setTargetValueAtTime): AudioParam.setTargetValueAtTime is misleading and underdefined

From: Olivier Thereaux <olivier.thereaux@bbc.co.uk>
Date: Fri, 29 Jun 2012 08:11:08 +0100
Message-ID: <4FED550C.6010508@bbc.co.uk>
To: Chris Rogers <crogers@google.com>
CC: Ray Bellis <ray@bellis.me.uk>, public-audio@w3.org
Hi Chris,

On 28/06/2012 19:26, Chris Rogers wrote:

> This is one method in a family of methods which include "AtTime" in
> their name:
>
> setValueAtTime()
> linearRampToValueAtTime()
> exponentialRampToValueAtTime()
> setTargetValueAtTime()
> setValueCurveAtTime()
>
> So I think it's important to maintain consistency here.

Yes, good point - we should either keep those as they are or change them 
all.

I note that the methods all use the "atTime" naming convention, rather 
than simply be called setValue, setTargetValue, etc because the latter 
set of names is used for the events. Is that correct?

Olivier



Received on Friday, 29 June 2012 07:11:42 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Friday, 29 June 2012 07:11:43 GMT