W3C home > Mailing lists > Public > public-appformats@w3.org > November 2007

Re: Widget 1.0 revision 1.52, wrong method name

From: Marcos Caceres <marcosscaceres@gmail.com>
Date: Mon, 5 Nov 2007 02:11:54 +1000
Message-ID: <b21a10670711040811x27bbb91ah79abd67eb42e49a0@mail.gmail.com>
To: "jouni hakala" <jouni.hakala@gmail.com>
Cc: public-appformats@w3.org
On 11/1/07, jouni hakala <jouni.hakala@gmail.com> wrote:
> Hi,
> Section 5.2 seems to have one mistake. Both names
> "getPreferenceForKey" and "preferenceForKey" are used. I think that
> the "preferenceForKey" is the correct one.

Woops! Fixed. Also fixed the text for setPreferenceForKey, which should
return void but was spec'd to return a boolean value. Returning void puts in
in line with Dashboard/Nokia Web Runtime. I'll make a few more updates
before I check in the changes.


Marcos Caceres
Received on Sunday, 4 November 2007 16:12:08 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 6 January 2015 20:50:08 UTC