W3C home > Mailing lists > Public > ietf-http-wg@w3.org > April to June 2013

Re: Design: Rename FRAME_TOO_LARGE to FRAME_SIZE_ERROR

From: Martin Thomson <martin.thomson@gmail.com>
Date: Wed, 19 Jun 2013 10:58:50 -0700
Message-ID: <CABkgnnUcFQEH5xL50qROdxmSvNotOh2rSoxoHp=3ASrKUm5O4A@mail.gmail.com>
To: William Chan (陈智昌) <willchan@chromium.org>
Cc: Jeff Pinner <jpinner@twitter.com>, Roberto Peon <grmocg@gmail.com>, HTTP Working Group <ietf-http-wg@w3.org>
On 19 June 2013 10:28, William Chan (陈智昌) <willchan@chromium.org> wrote:
> Actionable difference: it tells you what part of your stack to debug.
> PROTOCOL_ERROR is terrible :( Everytime we generate a PROTOCOL_ERROR, we
> have felt we wanted to add a debug string (that opaque byte sequence we
> discussed earlier) so we could figure out what was wrong.

I thought that was the reason you wanted to put the opaque stuff in the body.

The reason I'm pushing back is that it is possible to spend error code
bits on any amount of subdivision of the PROTOCOL_ERROR space.  Do you
want one for the case where someone didn't echo the bytes of a PING?
Or when they decide to send something else rather than continuing a
HEADERS block?  Or any of the many current and future
your-implementation-is-broken cases?  Ultimately, this just leads to a
blowout in error codes, to no good end.
Received on Wednesday, 19 June 2013 17:59:17 UTC

This archive was generated by hypermail 2.3.1 : Tuesday, 1 March 2016 11:11:13 UTC