W3C home > Mailing lists > Public > ietf-http-wg-old@w3.org > September to December 1996

Re: HTTP response version, again

From: Gregory J. Woodhouse <gjw@wnetc.com>
Date: Mon, 30 Dec 1996 10:13:37 -0800 (PST)
To: Blake Winton <bwinton@incontext.ca>
Cc: http-wg%cuckoo.hpl.hp.com@hplb.hpl.hp.com
Message-Id: <Pine.SGI.3.95.961230100215.15430B-100000@shellx.best.com>
On Mon, 30 Dec 1996, Blake Winton wrote:

> At 09:29 AM 12/30/96 -0800, Gregory Woodhouse wrote:
> >> It's not the response that being labeled by the HTTP/1.1 header, it's
> >> the server's capability.  There would be no reason to send an HTTP
> >> header if it only had to match the client's request.
> >A lot of people have said this, but I don't see where it is spelled out.
> 
> Well, in
> http://www.ics.uci.edu/pub/ietf/http/draft-ietf-http-v11-spec-07.txt
> (which I realize is just a draft, but still)...
> 
>   3.1 HTTP Version
> 
>   [snipped for brevity...]
> 
>   Applications sending Request or Response messages, as defined by this
>   specification, MUST include an HTTP-Version of "HTTP/1.1". Use of this
>   version number indicates that the sending application is at least
>   conditionally compliant with this specification.
> 
> It seems to be spelled out pretty clearly...
>

I'm not sure I agree with your intepretation. My take on the above is that

a) The message (request or response) complies with HTTP/1.1

AND

b) An application is not allowed to claim a version number for a message it
sends unless it is at least conditionally compliant with that version of
the protocol.

It seems to me tht you are interpreting the above paragraph as if though it
said:

Applications MUST send the highest version number with which they are at
least conditionally compliant in each message.

The difference is tht I see this paragraph as a protective measure to
prevent applications from claiming to support a version number with which
they are not at least conditionally compliant, not a requirement that
applications advertise the highest version number with which they are
compliant.
 
> Of course 3.1 also says
> 
>   Since the
>   protocol version indicates the protocol capability of the sender, a
>   proxy/gateway MUST never send a message with a version indicator which
>   is greater than its actual version; if a higher version request is
>   received, the proxy/gateway MUST either downgrade the request version,
>   respond with an error, or switch to tunnel behavior.
> 

Good example.

---
gjw@wnetc.com    /    http://www.wnetc.com/home.html
If you're going to reinvent the wheel, at least try to come
to come up with a better one.
Received on Monday, 30 December 1996 10:20:16 EST

This archive was generated by hypermail pre-2.1.9 : Wednesday, 24 September 2003 06:32:20 EDT