W3C home > Mailing lists > Public > ietf-http-wg-old@w3.org > January to April 1996

505 HTTP Version Not Supported

From: Roy T. Fielding <fielding@avron.ICS.UCI.EDU>
Date: Tue, 02 Apr 1996 18:36:07 -0800
To: http-wg%cuckoo.hpl.hp.com@hplb.hpl.hp.com
Message-Id: <9604021836.aa22304@paris.ics.uci.edu>
For the sake of completeness and the future of HTTP, I would like to
propose a new server error code for indicating that the server does
not support the HTTP protocol version received in the request message.

   505 HTTP Version Not Supported

   The server does not support, or refuses to support, the HTTP protocol
   version that was used in the request message.  The server is
   indicating that it is unable or unwilling to complete the request
   using the same major version as the client, as described in
   Section 3.1, other than with this error message.  The response should
   contain an entity describing why that version is not supported and
   what other protocols are supported by that server.


Please note that, among other things, this allows future applications
to cease support for older protocols and yet do so in a way that is
meaningful to older clients.


 ...Roy T. Fielding
    Department of Information & Computer Science    (fielding@ics.uci.edu)
    University of California, Irvine, CA 92717-3425    fax:+1(714)824-4056
    http://www.ics.uci.edu/~fielding/
Received on Tuesday, 2 April 1996 18:55:20 EST

This archive was generated by hypermail pre-2.1.9 : Wednesday, 24 September 2003 06:31:50 EDT