Re: checkout/checkin/uncheckout vs. lock/unlock

David G. Durand (dgd@cs.bu.edu)
Thu, 5 Nov 1998 12:19:07 -0400


Message-Id: <v04011702b2678020a0a9@[24.0.249.126]>
In-Reply-To: <9811031829.AA27687@tantalum>
Date: Thu, 5 Nov 1998 12:19:07 -0400
To: ietf-dav-versioning@w3.org
From: "David G. Durand" <dgd@cs.bu.edu>
Subject: Re: checkout/checkin/uncheckout vs. lock/unlock

At 2:29 PM -0400 11/3/98, Geoffrey M. Clemm wrote:
>Why was the checkout/checkin/uncheckout functionality assigned
>to the lock/unlock methods?  As I recall, in our last meeting,
>we agreed (or at least, all of us but Chris agreed, and Chris
>reluctantly accepted :-) that they each really needed to be a
>separate method.

> ... trimmed ...

>So I propose that we not overload lock/unlock, but that we have 3 new
>methods: CHECKIN, CHECKOUT, UNCHECKOUT.

This reflects my memory (and design taste) as well.

  -- David
_________________________________________
David Durand              dgd@cs.bu.edu  \  david@dynamicDiagrams.com
Boston University Computer Science        \  Sr. Analyst
http://www.cs.bu.edu/students/grads/dgd/   \  Dynamic Diagrams
--------------------------------------------\  http://www.dynamicDiagrams.com/
MAPA: mapping for the WWW                    \__________________________