W3C home > Mailing lists > Public > html-tidy@w3.org > January to March 2004

Re: "commented" CDATA for <style>!

From: Steffen Glückselig <steffen@gungfu.de>
Date: Wed, 04 Feb 2004 10:02:37 +0100
Cc: html-tidy@w3.org
To: "Bjoern Hoehrmann" <derhoermi@gmx.net>
Message-ID: <opr2t8qnnwmwd7yy@smtp.1und1.de>

Hello,

>> I'd like to second that. Additionally each time I run tidy, another
>> CDATA-section gets added. Resulting in things like
>> <style type="text/css">
>>   /*<![CDATA[*/
>>   /*<![CDATA[*/
>>   /*<![CDATA[*/
>>
>>   /*]]>*/
>>   /*]]>*/
>>   /*]]>*/
>>   </style>
>
> Could you send sample input/config options to reproduce this behaivour?

My configuration-file looks something like this:

markup: yes
wrap: 103
wrap-script-literals: no
wrap-asp: yes
break-before-br: yes
indent: auto
indent-spaces: 2
indent-attributes: no
uppercase-tags: no
uppercase-attributes: no
hide-endtags: no
enclose-text: yes
quote-marks: no
quote-nbsp: yes
quote-ampersand: yes
fix-backslash: yes
clean: yes
drop-font-tags: yes
logical-emphasis: yes
input-xml: no
assume-xml-procins: no
output-xml: yes
output-xhtml: yes
numeric-entities: no
add-xml-pi: no
show-warnings: yes
doctype: strict
char-encoding: ascii
wrap-attributes: yes
wrap-jste: yes
drop-empty-paras: yes
fix-bad-comments: yes
word-2000: no
numeric-entities: no
tidy-mark: no
add-xml-decl: yes
join-classes: no
escape-cdata: yes


Is there something wrong with it?


regards
Steffen
Received on Wednesday, 4 February 2004 04:00:56 UTC

This archive was generated by hypermail 2.3.1 : Wednesday, 5 February 2014 07:15:53 UTC