W3C home > Mailing lists > Public > html-tidy@w3.org > October to December 2000

RE: JTidy exception: IllegalAccessError

From: Michael Goldberg <MGoldberg@yet2.com>
Date: Thu, 21 Dec 2000 13:51:12 -0800
Message-ID: <D090FE9586C9D4119E4E00A02493157A05258C@ferris.tahoe.yet2.com>
To: "'Gary L Peskin'" <garyp@firstech.com>
Cc: "'html-tidy@w3.org'" <html-tidy@w3.org>
Gary,

Thanks for the quick response.  Yes, I am using Microsoft's JVM (installed
with Visual J++ 6.0) on Windows NT.  

I can't figure out if I have the Just In Time option set or not.  If I go to
Tools->Options and select "Debugger".  The "Just-In-Time debugger" checkbox
is checked.  I tried unselecting the checkbox, re-compiling, and re-running,
but that did not help.  Next, I went to the Compiler tab of my project's
properties and tried both -nojit and /nojit, but neither had an effect.
Interestingly, if I put in garbage for a compiler option, it still compiles
with any error messages, so I'm not sure if I am doing this correctly.

I can't figure out how to configure J++ to show me the actual compile/run
commands it uses, so I really can't confirm if I am using the jit option or
not.  Do you have specific instructions on how to turn off the just-in-time
compiler for Microsoft's J++ or how to configure it to display the compile
and run commands?

If not, I can try switching to Jbuilder to see if the problem goes away
there.

Thanks,
Michael

 -----Original Message-----
From: 	Gary L Peskin [mailto:garyp@firstech.com] 
Sent:	Thursday, December 21, 2000 10:37 AM
To:	Michael Goldberg
Cc:	'html-tidy@w3.org'
Subject:	Re: JTidy exception: IllegalAccessError

Michael Goldberg wrote:
> 
> All,
> 
> I am trying to use jtidy for the first time, but I get an
IllegalAccessError
> exception with the following stack trace:
> 
> java.lang.IllegalAccessError: org/w3c/tidy/ParserImpl: field _parseHead is
> inaccessible

Michael --

This is indeed pretty bizarre behavior.  In this case, it looks like the
inner class ParserImpl.ParseHTML is trying to accesss field _parseHead
directly.  However, the code in ParseHTML only accesses this field
through an accessor method but that method is not shown in your stack
trace.

I have seen wierd behavior like this in Microsoft JVMs.  What platform
are you on and what JVM are you using?  Try turning off the jit (-nojit)
and see if you still get this behavior.

HTH,
Gary
Received on Thursday, 21 December 2000 16:51:52 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 3 April 2012 06:13:45 GMT