W3C home > Mailing lists > Public > html-tidy@w3.org > April to June 2000

tidy for Linux

From: Winfried Boettcher <winfried.boettcher@libertysurf.fr>
Date: Sat, 10 Jun 2000 11:47:41 -0400 (EDT)
To: html-tidy@w3.org
Cc: bboett@erm1.u-strasbg.fr
Message-ID: <20000610090721.U6402@bestensee.libertysurf.fr>
Hi,
1) I tried to download tidy according to Dave Raggetts URL and ended up
   in France, on perso/club-internet.fr/dpo/rpm and could without problems
   download the rpm module. My computer runs a Suse Linux 6.0 distribution.
   I got this error message:
   > failed dependencies:
>         libc.so.6(GLIBC_2.0) is needed by tidy-30apr00-1
>         libc.so.6(GLIBC_2.1) is needed by tidy-30apr00-1

2) I removed the rpm files and bypassed the problem, by downloading from
   http://www.w3.org/People/Raggett/tidy/ the tgz files: 
   tidy30apr.tgz  
   tar xzf tidy30apr.tgz worked fine
   make                  worked fine
   make install          did not work.

3) execution of tidy on a html file produced by Staroffice with
   /home/wibo/tidy/tidy/tidy30apr00/tidy -f errs.txt -iucm file.html
   gave a much better html file, but the line numbers in errs.txt do NOT
   correspond with the line numbers which I can display with vim, :set nu
   except for the first line.

4) the warnings which I got look like this:
   Tidy (vers 30th April 2000) Parsing "proto-d2.html"
   line 1 column 1 - Warning: SYSTEM, PUBLIC, W3C, DTD, EN must be upper case
   line 27 column 2 - Warning: <table> lacks "summary" attribute
   Why does tidy in line 1 NOT change the words which should be in uppercase?
   As said above, in line27 there is no table.

Thank you very much and best regards 
Winfried B÷ttcher

=======================================================================
Winfried & Nicole BOETTCHER
81, av. Clair Ginet, F-83140 Six Fours les Plages
Tel. +33 4 94 07 01 89
e-mail: winfried.boettcher at iname.com
=======================================================================
Please check that in any reply the above mail address is generated !!!!
=======================================================================
Received on Tuesday, 20 June 2000 13:08:40 GMT

This archive was generated by hypermail 2.2.0+W3C-0.50 : Tuesday, 3 April 2012 06:13:44 GMT